Planet Emulation Forums

Planet Emulation Forums (https://forums.planetemu.net/index.php)
-   Général (https://forums.planetemu.net/forumdisplay.php?f=8)
-   -   [Multi] L'émulation sous OSX par Chaz (https://forums.planetemu.net/showthread.php?t=15188)

chaz 16/03/2018 20h12

Après mise à jour des émulateurs de Richard Bannister, je pense supprimer définitivement la page "émulateurs classiques" de mon dossier et la remplacer par une plus actualisée. De toute façon, même si je l'avais déjà dit plus haut, la portion d'utilisateurs jouant sur des systèmes antérieurs à 10.11 doit être anecdotique...

J'ai pas trop le temps de jouer en ce moment, mais j'ai téléchargé l'archive avec tous les émulateurs et je tâcherais d'en tester deux ou trois d'ici la semaine prochaine, les émulateurs Sega particulièrement, ayant quelques Roms "test" pour juger de la fiabilité et de la performance de ces programmes :cool2:

Petit coup de gueule cependant : il semblerait que le fameux "Emulator Enhancer" permettant de rajouter des options qui sont quand même de l'ordre du basique (plein écran, intégration HID...) soit toujours payant :angry:

Firebrand 16/03/2018 22h19

Emulator Enhancer est toujours un shareware en effet.

chaz 20/09/2018 23h43

Je viens de recevoir la dernière version de Open Emu (la 2.0.7).

Petit coup de gueule :

Citation:

Note: This is likely the last release to support OS X 10.11.
Ce qui veut probablement dire que la version 3 nécessitera un système ultérieur.

Je ne comprends vraiment pas. OSX 10.11 "El Capitan" est sorti en...2015 et il est très loin d'être considéré comme obsolète que ça soit par Apple ou les éditeurs tiers (la plupart demandent 10.9 ou 10.10 pour leurs applications). Pourquoi OpenEmu fait-t-il ce type d'écrémage en imposant des mises à jour de l'OS pour supporter ses versions les plus récentes ? :blink:

Firebrand 21/09/2018 00h04

La version de l'OS est relativement récente, mais ça comporte peut-être néanmoins du code legacy sur certains fonctions dont l'auteur doit préférer se débarrasser pour supporter par exemple la toute dernière version en date (devenue compatible).
J'ai l'impression que ça arrive assez souvent sous OSX. Les derniers en date étant Sixtyforce (passage de 10.7 à 10.8) et VirtuaC64 (passage de 10.10 à 10.11 sans même une annonce dans les release notes) de mémoire. Mais là, je reconnais que ça reste sur des versions déjà ancienne.
Sinon, il reste toujours RetroArch qui semble faire à peu près le même boulot (probablement moins léché graphiquement) mais en supportant des OS de plus en plus anciens.

chaz 28/10/2018 23h11

Je suis en train de mettre à jour Mame vers la version 0.202.

Information importante : à partir de la version 0.195, le front-end QMC2 n'accepte plus de version de Mame en deçà de ce numéro. Cependant, le dernier build "officiel" pour Mac OSX est bloqué à la version 0.192. Pour utiliser un Mame relativement récent sur Mac avec QMC2, il faudra donc compiler soi-même son front-end avec les dernières sources disponibles.

La compilation, parlons-en justement, elle peut générer des erreurs mais j'ai trouvé comment corriger ça, je met donc le tutorial à jour demain en conséquence :-)

En revanche je n'arrive plus à compiler une version de Mame, ça me génère des erreurs d'"arguments" que je n'arrive pas à déchiffrer. Il semblerait que la méthode n'ait pourtant pas changé. Je vais tenter de savoir ce qui se passe.

chaz 30/10/2018 15h20

Comme mentionné sur mon post précédent, j'ai procédé à quelques petites mises à jour de mes dossiers.

Rajout d'un petit speech expliquant comment modifier les sources de la librairie SDL en cas d'erreurs lors de la compilation de QMC2.

Actualisation de certaines instructions.

J'ai aussi supprimé la page "émulateurs classiques" (même si j'en ai conservé une copie sur un cloud perso au cas où...) : ces derniers étaient devenu vraiment obsolètes ou plus mis à jour...De toute manière les utilisateurs d'OS antérieurs à 10.9 doivent vraiment être marginaux à présent, encore plus dans le domaine de l'émulation et du retrogaming.

Je voulais essayer les nouvelles mises à jour des émulateurs de Richard Bannister, mais j'avoue honnêtement qu'installer de nouveau le shareware Emulator Enhancer me fait bien suer, d'autant plus que les sources sont à présent incluses dans OpenEmu (et très probablement Retroarch)

Dinofly 08/11/2018 22h26

Merci pour les updates chaz!
C'est clair que depuis OpenEmu est les cores Retroarch, les émulateurs standalone sur MacOS ont de moins en moins d'intérêt... surtout en shareware.

chaz 13/11/2018 20h39

"Secret of Mana" ne se lance plus sur OpenEmu en utilisant le core Snes9x (version 1.56.2) : l'écran reste désespérément noir.:cry:

Cependant, ça fonctionne très bien avec le core Higan.:)

chaz 04/12/2018 20h00

Avec la dernière MAJ de Open Emu, Secret of Mana fonctionne de nouveau avec le core Snes9X (en version 1.57) :cool2:

chaz 21/05/2019 21h58

Je voulais vous partager ce tweet de Roni, compilateur "officiel" de SDLMame pour Mac.

https://twitter.com/sdlmame_osx/stat...80299384086529

Du coup je m pose la question de savoir si les prochaines versions de SDLMame seront toujours compatible à partir de Mavericks comme avant. Y a plus qu'à attendre...

Firebrand 22/05/2019 05h49

Il a déjà répondu en fait:

Citation:

Will Sdlmame still be compatible with older versions of macosx ?


Yes. My dev environment is different than my play environment ;)

chaz 22/05/2019 09h10

Oui je sais c'est moi qui avait posé la question :nerd:

De toute façon, je ne pensais plus mettre à jour après la version 0.210. (pour avoir un chiffre rond). Pour des tas de raisons, mon mac est "bloqué" à El Capitan et je commence lentement mais sûrement à subir l'obsolescence programmée à la sauce Apple...

chaz 27/06/2019 17h44

Ci-joint les changes log de la dernière version de Open-Emu (la 2.0.9.1)

NOTE: This is the last version supporting OS X 10.11, macOS 10.12 and macOS 10.13. The next update will include major performance enhancements using Metal and exciting new features requiring a minimum of macOS 10.14.
Fixed input not working for some users in the initial 2.0.9 release.
Fixed the Library grid view appearing red in some instances on macOS 10.14 Mojave.
Fixed "Consolidate Files" not copying all the referenced files for CD-based games.
Added Chinese (Traditional) localization.
Updated Catalan, Italian localizations.

Firebrand 27/06/2019 22h47

Mais où les trouves-tu? Impossible de mettre la main dessus depuis la v2.0.7, que ce soit sur le site officiel, le wiki ou dans les archives de l'émulateur. :huh:

chaz 27/06/2019 22h56

Lors de la mise à jour en "push" tout simplement...mais du coup j'ai loupé les VRAIS changements (ceux de la version 2.0.9), ayant "zappé" cette éphémère version.

Firebrand 27/06/2019 23h05

Ah ouais, c'est donc limité aux utilisateurs de l'émulateur sous OSX. Merci l'auteur. <_<

chaz 27/06/2019 23h39

C'est aussi censé être indiqué ici : https://github.com/OpenEmu/OpenEmu/wiki/Release-notes

Mais effectivement, leur wiki ne semble plus très à jour.

chaz 03/07/2019 18h51

Depuis le 30 juin, à la suite de la fermeture de la plate-forme de paiement qui le permettait, il est devenu impossible d'acheter une licence pour Emulator Enhancer. Rappelons cependant que ce programme permettant d'activer toutes les fonctions des émulateurs de Richard Bannister n'est qu'un shareware symbolique. Vous pouvez l'utiliser gratuitement aussi longtemps que vous le souhaitez et l'acheter sert surtout à donner un coup de pouce au développeur.

Bannister précise aussi que la prochaine version de Emulator Enhancer, qui sortira en fin d'année, ainsi que les programmes associés, ne tourneront qu'à partir de Mac OS 10.14 "Mojave". Lui aussi est sans doute passé à l'API Metal pour ses futurs projets.

https://www.bannister.org/software/index.htm


Sinon, il n'est jamais trop tôt pour donner l'info. Macos 10.15 "Catalina", qui devrait sortir cet automne, ne supportera plus les applications 32 bits. Dans le monde de l'émulation, ça signifiera des adieux tout à fait officiels à MameOSX, Kega Fusion, PCSXReloaded et autres Magic Engine, programmes obsolètes mais toujours fonctionnels (et parfois utiles) dans l'état actuel des choses.

chaz 13/11/2019 14h38

Comme indiqué il y a quelques mois, OpenEmu exige à présent MacOs 10.14 minimum pour se lancer. Les utilisateurs d'une version antérieure du système d'exploitation resteront bloqués à la version 2.0.9.1.

Celle-ci fonctionne parfaitement et fait tourner tous les jeux du "commerce". Cependant, si à moyen terme il y a des changements importants dans l'interface et le fonctionnement global de l'application, je ne pourrais plus mettre le dossier et le tutoriel à jour -_-


Fuseau horaire GMT +2. Il est actuellement 08h44.

vBulletin® v.3.8.7, Copyright ©2000-2020, Jelsoft Enterprises Ltd.