Précédent   Planet Emulation Forums > Emulation > Emulateurs Ordinateurs

Emulateurs Ordinateurs Un problème avec les émulateurs de vieux ordinateurs comme l'Amiga ou l'Atari ST? Venez nous en parler!

Réponse
 
Outils de la discussion Modes d'affichage
Vieux 19/03/2017, 13h56   #1
Crazy C
Nouveau Membre
 
Avatar de Crazy C
 
Date d'inscription: 03/2017
Messages: 25
Crazy C sait se tenir
Icon14 UAE4ALL2/UAE4ARM Test/comparison/questions

Hello!

Since a while I'm testing UAE4ALL2 and UAE4ARM Amiga emulators for Android.
Lots of questions came up using and comparing them in several months and I hope to find some answers to them in this forum.
Also it seems there are still some bugs and things that need to be improved or at least I want to know if other users have similar problems with their emulators.

The versions I tested are UAE4ALL2 2.3.7.5 and UAE4ARM 1.0.0.16.
I mostly played GODS and SUPER CARS II which turned out to be best for use with the emulators.

Here's some 'report' of testing them...


UAE4ALL2

Has no stereo separation and collision detection setting

Autofire only available through control presets, not definable for custom control buttons

Autofire buttons and normal fire buttons exist separately (shortly tapping autofire buttons doesn't trigger fire)

Autofire 'medium' is in fact 'heavy' and 'heavy' doesn't do anything

Adding 0,5 MB slow ram causes Speedball 2 to crash when 'loading game'

What exactly is 'vsync'?


UAE4ARM

Lower performance in lots of parts of many demos

Slightly lower performance with lots of games especially when games are accessing Amiga disks

No additional button size setting like in UAE4ALL2 (see both emulators, device configuration's on screen keyboard size)

Autofire 'medium' and 'fast' are both the same ('fast')

When using the dpad as mouse, mouse speed 0,25 does nothing, only from 0,5 on the mouse speeds are supported

Virtual keyboard permanently changes from visible/invisible when about to enter a name for a custom configuration file

Playing Gods 'fast copper' setting causes background colour to change to green in some frames

When port0 and port1 are both set to 'none' and there are defined
two custom buttons for each 'mouse button left' (button 'A')
and 'mouse button right' ('button B'):
If you tap button 'A', no left mouse click is triggered,
port0 is suddenly automatically set to 'nubs as mouse' and only now
tapping button 'A' again triggers a left mouse click.
The same with button 'B' and port1:
If I tap button 'B' port1 now is set to 'nubs as mouse' and tapping
button 'B' only now really triggers a right mouse click!

When running 'World of Commodore Amiga' demo from Sanity:
The first effect (zoom of logo) is accelerated with 'fast copper' on.

In menu (chosing directory/file) some unicode characters (Ü for example) are not supported

'JIT' slows down emulation instead of improving performance

Dms and zip work, adz don't


BOTH EMULATORS

No manual

Amiga disks always not write protected

Device configuration's left mouse click setting 'hold at the same spot' seems not to work sometimes or conflicts with 'tap delay' setting

Don't understand device configuration's 'relative mouse movement', 'video settings' and 'multiple touch events per video frame'

Device configuration's 'on screen keyboard/button images size' is always one level smaller than it should be (large is in fact medium)
Only if you use UAE4ALL2's button size setting, large is really large (UAE4ARM does not have this option, so 'medium' size buttons are the largest with that emulator)

When playing the game 'GODS':
If player positioned in the right part of the screen looking to the right or positioned in the left part of the screen looking to the left:
Autofire triggers fire correctly (no pauses between firing)
If player positioned in the right part of the screen looking to the left or positioned in the left part of the screen looking to the right:
Autofire triggers 3 times fire - pause - 3 times fire - pause...

Floppy drive speed x 2/8 etc. slows down emulation significantly


That's it.

Finally, some information about my Phone:

Samsung Galaxy J1 (J100H)
Device: j13g
Board: sc7727s
Hardware: sc8830
Processor: ARMv7 Processor rev 5 (v7l)
Instruction sets: armeabi-v7a, armeabi
CPU features: swp half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt
CPU hardware: sc8830
Cores: 2
Clock speed: 768 MHz - 1200 MHz
Resolution: 480 x 800 pixel
Density: 240 dpi (hdpi)
Refresh rate: 60.001 Hz
RAM: 452,9 MB
Android: 4.4.4 KITKAT, API level 19
Kernel: Linux, armv7l, 3.10.17-1042529
Android runtime: Dalvik 1.6.0
Not rooted

Thanks for reading and I'd be grateful for any help!

Dernière modification par Crazy C ; 22/03/2017 à 23h32.
Crazy C est déconnecté   Réponse avec citation
Vieux 20/03/2017, 18h05   #2
ShaDoW69
Redacteurs
 
Avatar de ShaDoW69
 
Date d'inscription: 02/2017
Localisation: Campagne, St-Sanconnexion
Messages: 42
ShaDoW69 sait se tenir
Sorry I can't help you but maybe I will install a emulator for Amiga, my tablet specifications.
__________________
Je suis quelqu'un.
Sega, c'est plus fort que toi !
ShaDoW69 est déconnecté   Réponse avec citation
Vieux 22/03/2017, 22h08   #3
Crazy C
Nouveau Membre
 
Avatar de Crazy C
 
Date d'inscription: 03/2017
Messages: 25
Crazy C sait se tenir
Icon1 Testing the emulators on your tablet

It would be nice if some people test the emulators, too and interesting for me to know whether others have the same bugs and problems...
Don't know about you having experience with the Amiga and the configuration of the emulators...
Crazy C est déconnecté   Réponse avec citation
Vieux 22/03/2017, 22h35   #4
ShaDoW69
Redacteurs
 
Avatar de ShaDoW69
 
Date d'inscription: 02/2017
Localisation: Campagne, St-Sanconnexion
Messages: 42
ShaDoW69 sait se tenir
Citation:
Envoyé par Crazy C Voir le message
It would be nice if some people test the emulators, too and interesting for me to know whether others have the same bugs and problems...
Don't know about you having experience with the Amiga and the configuration of the emulators...
I'm gonna test UAE4ARM
__________________
Je suis quelqu'un.
Sega, c'est plus fort que toi !
ShaDoW69 est déconnecté   Réponse avec citation
Vieux 22/03/2017, 23h36   #5
Crazy C
Nouveau Membre
 
Avatar de Crazy C
 
Date d'inscription: 03/2017
Messages: 25
Crazy C sait se tenir
Icon1 Testing UAE4ARM

Nice, good luck!
Crazy C est déconnecté   Réponse avec citation
Vieux 09/06/2017, 13h36   #6
Crazy C
Nouveau Membre
 
Avatar de Crazy C
 
Date d'inscription: 03/2017
Messages: 25
Crazy C sait se tenir
Icon14 Testing UAE4ARM

Some time has passed now. And could you test it?
Did you notice the same problems with the emulators?

Dernière modification par Crazy C ; 12/06/2017 à 13h57.
Crazy C est déconnecté   Réponse avec citation
Réponse


Utilisateurs regardant la discussion actuelle : 1 (0 membre(s) et 1 invité(s))
 
Outils de la discussion
Modes d'affichage

Règles de messages
Vous ne pouvez pas créer de nouvelles discussions
Vous ne pouvez pas envoyer des réponses
Vous ne pouvez pas envoyer des pièces jointes
Vous ne pouvez pas modifier vos messages

Les balises BB sont activées : oui
Les smileys sont activés : oui
La balise [IMG] est activée : oui
Le code HTML peut être employé : non

Navigation rapide

Discussions similaires
Discussion Auteur Forum Réponses Dernier message
Questions Ma Teng Emulateurs Consoles 6 25/04/2007 16h16
3 Questions Sur Msn Silvers Hardware et Software 11 26/02/2004 03h43
Qq Questions Sur L'emu Cd CoinCoin Emulateurs Consoles 1 17/10/2003 21h49
Questions sur u64 gamecube2 Emulateurs Arcade 13 06/12/2002 01h29
Questions Baran Emulateurs Arcade 2 18/09/2002 02h41


Fuseau horaire GMT +2. Il est actuellement 13h14.


vBulletin® v.3.8.7, Copyright ©2000-2018, Jelsoft Enterprises Ltd.